Добавление зависимостей ZXing android embedded

Я начал новый проект в Android Studio, и я хочу импортировать zxing-android-embedded, чтобы я мог создать простой сканер штрих-кода в моем приложении. Найденный здесь на github

Следуя инструкциям там, а также по разным источникам, вроде этого SO ответ: https://stackoverflow.com/a/23788163/3364482

Однако я добавил компиляцию optins к моему, build.gradleно я получаю ошибки «Не удалось разрешить»:

Не удалось разрешить: com.google.zxing: core: 3.2.0
Не удалось решить: com.journeyapps: zxing-android-embedded: 2.3.0
Не удалось решить: com.journeyapps: zxing-android-integration: 2.3.0

Но насколько я знаю, мой buid.gradle соответствует инструкциям:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.1"

defaultConfig {
    applicationId "com.myapps.practice.helloworld"
    minSdkVersion 19
    targetSdkVersion 23
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}
}
repositories {
    jcenter()
}
dependencies {
    compile 'com.journeyapps:zxing-android-embedded:2.3.0@aar'
    compile 'com.journeyapps:zxing-android-integration:2.3.0@aar'
    compile 'com.google.zxing:core:3.2.0'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'
}

EDIT: Я не в автономном режиме.

java,android,android-studio,zxing,

2

Ответов: 3


2

Попробуйте это, это самая последняя версия из git:

dependencies {
    compile 'com.journeyapps:zxing-android-embedded:3.2.0@aar'
    compile 'com.google.zxing:core:3.2.1'
    compile 'com.android.support:appcompat-v7:23.1.0'   // Version 23+ is required
}

android {
    buildToolsVersion '23.0.2' // Older versions may give compile errors
}

0

Есть мой файл gradle:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "space.klapeyron.testqr"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'

    //added by Klapeyron start
    compile 'com.journeyapps:zxing-android-embedded:3.2.0@aar'
    compile 'com.google.zxing:core:3.2.1'
    compile 'com.android.support:appcompat-v7:23.1.0'   // Version 23+ is required
    //added by Klapeyron end
}

//added by Klapeyron start
repositories {
    jcenter()
}
//added by Klapeyron end

0

В моем случае мне пришлось обновить мою градулу до 3.4 и использовать ее вместо компиляции:

dependencies {
   implementation 'com.journeyapps:zxing-android-embedded:3.0.2@aar'
   implementation 'com.google.zxing:core:3.2.0'
   //...
}

Возможно, вам также понадобится очистить кеш и перезапустить, если он все еще не работает.

Java, Android, андроид-студия, ZXing,
Похожие вопросы