BrowserslistError: Неизвестный браузер

Я пытаюсь использовать bootstrap 4 с моей угловой установкой. Я запустил npm install --save bootstrap @ next, но у меня есть разрыв во время выполнения:

./node_modules/css-loader?{"sourceMap":false,"importLoaders":1}!./node_modules/postcss-loader/lib?{"ident":"postcss","plugins":[null,null,null],"sourceMap":false}!./node_modules/bootstrap/dist/css/bootstrap.min.css
Module build failed: BrowserslistError: Unknown browser major
    at error (C:xampphtdocs	ick_master_angularweb
ode_modulesrowserslistindex.js:37:11)
    at Function.browserslist.checkName (C:xampphtdocs	ick_master_angularweb
ode_modulesrowserslistindex.js:320:18)
    at Function.select (C:xampphtdocs	ick_master_angularweb
ode_modulesrowserslistindex.js:438:37)
    at C:xampphtdocs	ick_master_angularweb
ode_modulesrowserslistindex.js:207:41
    at Array.forEach (native)
    at browserslist (C:xampphtdocs	ick_master_angularweb
ode_modulesrowserslistindex.js:196:13)
    at Browsers.parse (C:xampphtdocs	ick_master_angularweb
ode_modulesautoprefixerlibrowsers.js:44:14)
    at new Browsers (C:xampphtdocs	ick_master_angularweb
ode_modulesautoprefixerlibrowsers.js:39:28)
    at loadPrefixes (C:xampphtdocs	ick_master_angularweb
ode_modulesautoprefixerlibautoprefixer.js:56:18)
    at plugin (C:xampphtdocs	ick_master_angularweb
ode_modulesautoprefixerlibautoprefixer.js:62:18)
    at LazyResult.run (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:270:20)
    at LazyResult.asyncTick (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:185:32)
    at LazyResult.asyncTick (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:197:22)
    at processing.Promise.then._this2.processed (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:224:20)
    at LazyResult.async (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:221:27)
    at LazyResult.then (C:xampphtdocs	ick_master_angularweb
ode_modulespostcss-loader
ode_modulespostcssliblazy-result.js:127:21)
 @ ./node_modules/css-loader?{"sourceMap":false,"importLoaders":1}!./node_modules/postcss-loader/lib?{"ident":"postcss","sourceMap":false}!./src/styles.css 3:10-190
 @ ./src/styles.css
 @ multi ./src/styles.css

Может кто-нибудь помочь, пожалуйста?

javascript,angular,bootstrap-4,

15

Ответов: 9


уя 14

Проблема может заключаться в том, что вы получили последнюю версию с некоторой ошибкой. Я заметил, что bootstrap@4.0.0-beta.3 вызывает эту проблему, но не bootstrap@4.0.0-beta.2. Проверьте, совпадает ли ваш. Попробуйте удалить и запустить что-то с определенной версией.

npm install bootstrap@4.0.0-alpha.6

Это решило мою проблему.


12 ов

Появилась новая версия Bootstrap, которая является v4.0.0-beta.2, и ваш пакет.json имеет ^ bootstrap4.0.0-alpha.6, поэтому новая версия начальной загрузки требует зависимости списка браузеров.

Чтобы запустить приложение, удалите последнюю версию тега (^) и запустите команду npm install


Для Bootstrap 4.0.0 (выпуск) мне нужно обновить CLI до 1.6.5 и работать!

  "dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "1.0.0-beta.9",
    "bootstrap": "4.0.0",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "jquery": "^3.2.1",
    "popper.js": "^1.12.9",
    "rxjs": "^5.5.2",
    "zone.js": "^0.8.14"
  },
  "devDependencies": {
    "@angular/cli": "^1.6.5",
    "@angular/compiler-cli": "^5.0.0",
    "@angular/language-service": "^5.0.0",
    "@types/jasmine": "~2.5.53",
    "@types/jasminewd2": "~2.0.2",
    "@types/node": "~6.0.60",
    "codelyzer": "^4.0.1",
    "jasmine-core": "~2.6.2",
    "jasmine-spec-reporter": "~4.1.0",
    "karma": "~1.7.0",
    "karma-chrome-launcher": "~2.1.1",
    "karma-cli": "~1.0.1",
    "karma-coverage-istanbul-reporter": "^1.2.1",
    "karma-jasmine": "~1.1.0",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.1.2",
    "ts-node": "~3.2.0",
    "tslint": "~5.7.0",
    "typescript": "~2.4.2"
  }

Я обновился до Angular CLI 1.7.x, и он начал работать нормально. Я рекомендую это решение. Я имею в виду модернизацию Угловой CLI, и она должна работать для вас!

Другим обходным решением является удаление следующих строк из node_modules / bootstrap / package.json

"browserslist": [
"last 1 major version", <----- delete this line
">= 1%", <----- delete this line
"Chrome >= 45",
"Firefox >= 38",
"Edge >= 12",
"Explorer >= 10",
"iOS >= 9",
"Safari >= 9",
"Android >= 4.4",
"Opera >= 30"
],

2

Была ли такая же проблема изменилась моя зависимость в package.json из этого

"dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "^1.0.0-beta.9",
    "bootstrap": "^4.0.0-beta.3",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "zone.js": "^0.8.14"
  }

(изменение «bootstrap»: «4.0.0-beta.2» до стабильной версии)

"dependencies": {
    "@angular/animations": "^5.0.0",
    "@angular/common": "^5.0.0",
    "@angular/compiler": "^5.0.0",
    "@angular/core": "^5.0.0",
    "@angular/forms": "^5.0.0",
    "@angular/http": "^5.0.0",
    "@angular/platform-browser": "^5.0.0",
    "@angular/platform-browser-dynamic": "^5.0.0",
    "@angular/router": "^5.0.0",
    "@ng-bootstrap/ng-bootstrap": "^1.0.0-beta.9",
    "bootstrap": "4.0.0-beta.2",
    "core-js": "^2.4.1",
    "font-awesome": "^4.7.0",
    "zone.js": "^0.8.14"
  },

затем запустите: npm install ng serve

задача решена.!!

JavaScript, угловые, самозагрузки-4,
Похожие вопросы