Webpack2: require не определен

Ответов: 0

Webpack2: require не определен

Я получаю эту ошибку в app.js:

Uncaught ReferenceError: require не определен

Почему веб-пакет не требует работы? Требуется ли дополнительная настройка wabpack для этой работы?

webpack.config.js

var webpack = require('webpack');
var ExtractTextPlugin = require('extract-text-webpack-plugin');

module.exports = {
  entry:  ['./src/app.js', './src/styles/styles.scss'],
  output: {
    filename: 'dist/bundle.js'
  },
  resolve: {
    extensions: ['.js'],
  },
  module: {
    rules: [
      { // regular css files
        test: /.css$/,
        loader: ExtractTextPlugin.extract({
          loader: 'css-loader?importLoaders=1',
        }),
      },
      { // sass / scss loader for webpack
        test: /.(sass|scss)$/,
        loader: ExtractTextPlugin.extract(['css-loader', 'sass-loader'])
      },
      {
        test: /.hbs$/,
        loader: 'handlebars-loader'
      }
    ]
  },
  plugins: [
    new ExtractTextPlugin({ // define where to save the file
      filename: 'dist/[name].bundle.css',
      allChunks: true,
    }),
  ],
};

app.js

const something = require("./something.js");
01JavaScript, WebPack, WebPack-2,
Похожие вопросы