websphere 8.5.5.6 сервер с java 6 и 7, но мне нужно java 8 как добавить java sdk к существующему серверу websphere

Я установил 8.5.5.6 в моей системе. когда я пытаюсь добавить в eclipse его показную среду исполнения Jre как

  1. Сервер приложений веб-сферы java 1.6, 64 бит и
  2. Сервер приложений веб-сферы java 1.7, 64 бит

Но мне нужно работать с java 1.8, который уже установлен, но сервер jre не существует по умолчанию java 1.7 есть ли мой вопрос, как добавить или обновить Java 1.8 в веб-сфере

когда я попытался запустить сервер, он показывает ниже ошибки:

Ошибка WebSphere Application Server Ошибка WebSphere Application Server

Проект xxxxxx построен с Java SDK 8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5. Проект xxxx построен с Java SDK 1.8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5. Проект xxxxxx построен с Java SDK 1.8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5.

java,eclipse,websphere,java-8,websphere-8,

3

Ответов: 5


Но мне нужно работать с java 1.8, который уже установлен, но сервер jre не существует по умолчанию java 1.7 есть ли мой вопрос, как добавить или обновить Java 1.8 в веб-сфере

когда я попытался запустить сервер, он показывает ниже ошибки:

Ошибка WebSphere Application Server Ошибка WebSphere Application Server

Проект xxxxxx построен с Java SDK 8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5. Проект xxxx построен с Java SDK 1.8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5. Проект xxxxxx построен с Java SDK 1.8, который несовместим с сервером, работающим на Java SDK 7. Попробуйте опубликовать приложение на более поздней версии WebSphere Application Server. Или попробуйте увеличить JRE сервера, если вы используете WebSphere Application Server V8.5.

53
3 принят

Java 8 поддерживается только WebSphere Liberty 8.5.5.6. Если вы используете полный профиль WebSphere Application Server, поддерживаются только Java 7 и 6.


2

Java 8 теперь доступен на Full WAS 8.5.5.9. Его можно скачать здесь . Java 8 поддерживается только в этих операционных системах .


1

Java 8 теперь поддерживается в классическом профиле WebSphere пакетом исправлений 8.5.5.9 в соответствии с документацией здесь: http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg27005002

WebSphere 8.5.5 Java 8.0 (Свобода только от 8.5.5.5, Классический WebSphere из 8.5.5.9)


1

Это то, что я сделал. Надеюсь, это поможет будущим пользователям.

1) Я обновился до 8.5.5.10.
2) Перейдите на страницу
http://www-01.ibm.com/support/docview.wss?uid=swg24042600#SDK80,
а затем нажмите на первую ссылку («Java SDK 8.0.3.0 ... ")
3) Нажмите, чтобы загрузить соответствующий файл. (для Windows, 8.0.3.0-WS-IBMWASJAVA-Win.zip)
4) Извлеките файл в какое-то место.
5) Откройте диспетчер установки IBM и настройте репозиторий, как указано выше.
6) Затем нажмите «Установить ссылку» в менеджере установки.
7) Выберите (IBM Java SDK для сервера приложений).
8) Затем просто перейдите к началу установки.
9) Запустите сервер и перейдите по следующему пути.
Серверы приложений> server1> Java SDK. Вы увидите как Java 8, так и Java 6.
10) Выберите Java 8 и нажмите «Сделать по умолчанию».
11) Перезагрузите сервер.
12) Это он


-1
  1. Перейдите к пути, где установлена ??веб-страница. C: IBM WebSphere AppServer85 bin

  2. managesdk.bat a € "listAvailabl

  3. managesdk.bat -listEnabledProfile -profileName {Имя профиля ex-AppSrv01} -verbose
  4. managesdk.bat -enableProfile -profileName {Имя профиля ex-AppSrv01} -sdkname 1.7_32 {или 1.7_64} - enableServers

  5. Закрыть RAD (если он открыт)

  6. Повторно открыть RAD
  7. Щелкните правой кнопкой мыши сервер, настроенный с помощью среды выполнения JDK 7, в представлении серверов> Свойства> Сервер приложений WebSphere.

Версия JVM теперь должна иметь значение sdkname (например, 1.7_64, как показано ниже):

  1. Опубликуйте свое приложение в RAD
Java, Eclipse, WebSphere, Java-8, 8-WebSphere,
Похожие вопросы