Active-sqlserver-адаптер с приложением Rails 5.

Я пытаюсь создать новое приложение с рельсами 5. У меня есть полдюжины приложений, отлично работающих с рельсами 4.x.

Когда я пытаюсь установить пакет, я получаю сообщение об ошибке, которое начинается с

Error:[rake --tasks] DEPRECATION WARNING: alias_method_chain is deprecated. Please, use Module#prepend instead. From module, you can access the original method using super. (called from <top (required)> at C:/Users/cmendla/RubymineProjects/user_message_console/config/application.rb:7)
DEPRECATION WARNING: alias_method_chain is deprecated. Please, use Module#prepend instead. From module, you can access the original method using super. (called from <top (required)> at C:/Users/cmendla/RubymineProjects/user_message_console/config/application.rb:7)
rake aborted!
Bundler::GemRequireError: There was an error while trying to load the gem 'activerecord-sqlserver-adapter'.
Gem Load Error is: undefined method `add_order!' for class `Class'
Backtrace for gem load error is:

Если я делаю шоу-шоу, я получаю

C:UserscmendlaRubymineProjectsuser_message_console>bundle show activerecord
C:/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/activerecord-5.0.0.1

Я пробовал как простой камень, так и драгоценный камень с разными версиями

gem 'tiny_tds'
# gem 'activerecord-sqlserver-adapter', '~> 5.0.0'
 gem 'activerecord-sqlserver-adapter'

Установка пакета показывает код ошибки 0

Using activerecord-sqlserver-adapter 2.3.8
(this is a partial list ).....
Using sprockets-rails 3.2.0
Using coffee-rails 4.2.1
Using jquery-rails 4.2.1
Using web-console 3.4.0
Using rails 5.0.0.1
Using sass-rails 5.0.6
Bundle complete! 14 Gemfile dependencies, 58 gems now installed.
Use `bundle show [gemname]` to see where a bundled gem is installed.

Process finished with exit code 0

Но затем я получаю сообщение об ошибке, которое я написал выше. Там сервер, который я использую, - это сервер 2012

Существует некоторая информация на странице https://github.com/rails-sqlserver/activerecord-sqlserver-adapter/tree/rails5, но мне не кажется, что я загружаю правильную версию gem, так как ссылки на этот документgem 'activerecord-sqlserver-adapter', '~> 4.2.0'

Если кто-нибудь знает о проблемах совместимости между rails 5 и ActiveRecord SQL Server Adapter, я могу немного поработать с rails 4.x. В противном случае я хотел бы попытаться заставить это работать.

ruby-on-rails,sql-server,activerecord,tiny-tds,

0