Не найден ресурс, который соответствует указанному имени (в 'cardBackgroundColor' со значением '? Android: attr / colorBackgroundFloating')

При попытке компиляции я получаю эти два сообщения об ошибке:

/Users/dericw/coding/myApplication/lfdate/android/app/build/intermediates/exploded-aar/com.android.support/cardview-v7/23.2.1/res/values-v23/values-v23.xml
Error:(3, 5) No resource found that matches the given name (at 'cardBackgroundColor' with value '?android:attr/colorBackgroundFloating').
Error:Execution failed for task ':app:processDebugResources'.
> com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command '/Users/dericw/Library/Android/sdk/build-tools/23.0.2/aapt'' finished with non-zero exit value 1

Android Studio затем открывается v23/values-23.xmlс этим стилем:

    <style name="CardView" parent="Base.CardView">
        <item name="cardBackgroundColor">?android:attr/colorBackgroundFloating</item>
    </style>

Но у меня нет такого определения в моем приложении. Это сгенерированный файл, который дает мне ошибку. Я довольно сильно обеспокоен тем, как исправить эту проблему? Кто-нибудь сталкивался с этим раньше? Как это исправить?

Файл сборки проекта

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:1.5.0'
        classpath 'com.google.gms:google-services:2.0.0-alpha6'
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

Файл сборки приложения

buildscript {
    repositories {
        mavenCentral()
        maven {
            url 'https://maven.fabric.io/public'
        }
    }

    dependencies {
        classpath 'io.fabric.tools:gradle:1.+'
    }
}

apply plugin: 'com.android.application'
apply plugin: 'io.fabric'

android {
    compileSdkVersion 22
    buildToolsVersion '23.0.2'

    defaultConfig {
        applicationId "com.something.myapp"
        minSdkVersion 16
        targetSdkVersion 22
        versionCode 200
        versionName "1.7.1"
    }

    buildTypes {
        debug {
            versionNameSuffix '-debug'
        }
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
            signingConfig signingConfigs.release
            zipAlignEnabled true
        }
    }

    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/NOTICE'
        exclude 'META-INF/LICENSE'
        exclude 'META-INF/LICENSE.txt'
        exclude 'META-INF/NOTICE.txt'
    }

    sourceSets {
        androidTest.setRoot('src/test')
    }
}

repositories {
    mavenCentral()
    maven {
        url 'https://oss.sonatype.org/content/repositories/snapshots/'
    }
    maven {
        url 'https://maven.fabric.io/public'
    }
}

dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile('com.crashlytics.sdk.android:crashlytics:2.4.0@aar') {
        transitive = true;
    }
    compile('org.apache.httpcomponents:httpmime:4.3.6') {
        exclude module: 'httpclient'
    }
    compile project(':viewPagerIndicator')
    compile 'com.android.support:appcompat-v7:22.2.1'
    compile 'com.android.support:cardview-v7:22.2.1'
    compile 'com.android.support:recyclerview-v7:22.2.1'
    compile 'com.android.support:design:22.2.1'
    compile 'com.facebook.android:facebook-android-sdk:4.+'
    compile 'com.mcxiaoke.volley:library:1.+'
    compile 'com.parse.bolts:bolts-android:1.+'
    compile 'com.parse:parse-android:1.+'
    compile 'com.google.android.gms:play-services-gcm:8.3.0'
    compile 'com.google.android.gms:play-services-analytics:8.3.0'
    compile 'joda-time:joda-time:2.+'
    compile 'com.koushikdutta.async:androidasync:2.+'
    compile 'com.edmodo:rangebar:1.+'
    compile 'org.lucasr.twowayview:twowayview:0.+'
    compile 'com.github.amlcurran.showcaseview:library:5.4.+'
    compile 'com.nostra13.universalimageloader:universal-image-loader:1.+'
    compile 'com.getbase:floatingactionbutton:1.+'
    compile 'com.mixpanel.android:mixpanel-android:4.+'
    compile 'org.apache.httpcomponents:httpclient-android:4.3.5'
    compile 'com.wefika:flowlayout:0.+'
    compile 'com.hudomju:swipe-to-dismiss-undo:1.+'
    compile 'com.soundcloud.android:android-crop:1.0.1@aar'
    compile 'com.squareup.picasso:picasso:2.+'
}

apply plugin: 'com.google.gms.google-services'

android,android-support-library,android-cardview,build-tools,

26

Ответов: 7


53 принят

компилировать 'com.facebook.android:facebook-android-sdk:4.+' нужен V-23

Измените версию SDK в facebook версии 4.8.0, после чего он не будет использовать этот файл ресурсов. Тогда ваш код будет запущен и запущен /


32 ов

У меня также был этот вопрос. Я решил, выставив более старую версию библиотеки карт, поскольку проблема с этим.

compile('com.android.support:cardview-v7:23.2.0') {
    force = true
}

Вопрос был с 23.2.1 вида карты, SDK Facebook использует эту библиотеку.


2

Если вы используете плагин «cordova-plugin-facebook4», удалите плагин из своего проекта и вытащите его снова (последняя версия), а затем добавьте его обратно в свой проект.

В то же время, пожалуйста, проверьте файл xml, который находится на yourCordovaProject/plugin/cordova-plugin-facebook4/plugin.xmlлинии № 64, это должно быть 4.8.+:

<framework src="com.facebook.android:facebook-android-sdk:4.8.+"/>


0
  1. Для временного исправления я решил изменить свою проблему project.properties:

vi platform / android / project.properties

и изменено с target = android-22 на target = android-23

  1. Для постоянного исправления вам просто нужно обновить платформу Android:

Обновление платформы платформы cordova android --save


0

Для пользователей Phonegap Build попробуйте это. Это сработало для меня.

<plugin spec="https://github.com/jeduan/cordova-plugin-facebook4#aff9a08a86cc6c6a18019f7adc2896ddf97c11cd" source="git" >
андроид, андроид-поддержка-библиотека, андроид-cardview, встроенный инструмент,
Похожие вопросы