Невозможно установить пакеты в Pycharm

У меня есть версия сообщества pycharm (последняя стабильная сборка), установленная на моем Ubuntu 16.04 LTS, я не могу устанавливать пакеты через pycharm, смог установить их раньше. Я могу установить пакеты через pip, но хотел бы решить эту проблему.

Ниже приведен скриншот проблемы

введите описание изображения здесь

Если бы у вас возникли проблемы с этим вопросом, но я не смог найти никакого исправления, у меня есть машина для Windows, и она не сталкивается с той же проблемой.

python,pycharm,

14

Ответов: 2


9 принят

У меня есть решение, я написал https://youtrack.jetbrains.com/issue/PY-20081#u=1468410176856 .

Здесь они попытались добавить https://pypi.python.org/pypi в качестве репозитория.

Чтобы добавить его в качестве репозитория,

1.) Go to Settings
2.) Project interpreter
3.) Click the + sign on top right edge
4.) Go to manage repositories, 
5.) Press the + Sign, then add https://pypi.python.org/pypi
6.) Press Ok

Теперь все пакеты должны загружаться.

Спасибо Hami Torun & Simon, я смог решить это удачей.


3

Я была такая же проблема. Это случилось внезапно, день назад я смог выполнить пакеты или установить пакеты, но на следующий день появилась ошибка. Однако это помогло (я использовал версию PyCharm Community Edition 2018):

Перейдите в Настройки -> Переводчик проекта -> нажмите зеленый значок «+» (справа) -> Управление репозиториями (внизу) -> удалить https://pypi.python.org/simple -> добавить https: // pypi. python.org/pypi, затем нажмите «ОК». Repo снова вернется как / просто, но не беспокойтесь, ошибка должна исчезнуть, и вы снова сможете установить пакеты.

питон, PyCharm,
Похожие вопросы