Ошибка Cocoa Pods с установкой pod

[!] Невозможно удовлетворить следующие требования:

  • Google/SignIn требуемый Podfile
  • Google/SignIn требуемый Podfile
  • Google/SignIn требуемый Podfile
  • Google/SignIn требуемый Podfile
  • Google/SignIn (= 1.3.2) требуемый Podfile.lock

Google/SignInБыли найдены спецификации, удовлетворяющие зависимости, но они требовали более высокой минимальной цели развертывания.

Google/SignInБыли найдены спецификации, удовлетворяющие зависимости, но они требовали более высокой минимальной цели развертывания.

Google/SignInБыли найдены спецификации, удовлетворяющие зависимости, но они требовали более высокой минимальной цели развертывания.

Google/SignInБыли найдены спецификации, удовлетворяющие зависимости, но они требовали более высокой минимальной цели развертывания.

Google/SignIn (= 1.3.2)Были найдены спецификации, удовлетворяющие зависимости, но они требовали более высокой минимальной цели развертывания.

ios,cocoapods,

6

Ответов: 5


14

Your deployment target has to be moved up to the highest minimum target required by any dependency. введите описание изображения здесь Кроме того, убедитесь, что глобальная платформа в вашем подпиксе соответствует максимальной минимальной цели, требуемой любой зависимостью.


2

Это довольно понятно. Цель развертывания должна быть перенесена на максимальную минимальную цель, требуемую любой зависимостью. Проверьте, какая версия iOS для Google / SignIn требуется. Если это проверит, убедитесь, что все ваши цели развертывания заданы удовлетворительной минимальной целевой версией.


1

я решил это, удалив мою версию Google / SignIn и снова установив мои контейнеры.


0

Я думаю, что Google / SignIn SDK поддерживает iOS7 или более позднюю версию. Попробуйте более высокий минимальный целевой показатель развертывания.


0

Я решил проблему. Я выбрал свой проект в верхней части моего навигатора проектов -> Общие -> Информация о развертывании -> Цель развертывания -> (Установить самый последний)?

ИОС, cocoapods,
Похожие вопросы