Неверная версия жгута зависимости при выполнении теста для моего драгоценного камня

Я развиваю драгоценный камень. Для тестирования моего драгоценного камня я использую ActiveRecord. Когда я запускаю тест, я получаю некоторую ошибку, потому что мой драгоценный камень не поддерживает версию 5.0 ActiveRecord.

Но в моем gemspec у меня есть:

spec.add_development_dependency 'activerecord', '~> 4.2'

Также я попытался использовать Gemfile.local, но не получил положительного результата.

Какой правильный способ установить конкретную версию для драгоценного камня?

ruby-on-rails,activerecord,rubygems,

0

Ответов: 1


0 принят

Я выяснил, что проблема была в моем файле test_helper:

begin
  require File.dirname(__FILE__) + '/../../../../config/environment'
rescue LoadError
  require 'rubygems'
  gem 'activerecord'
  gem 'actionpack'
  require 'active_record'
 end

Когда я установил явную версию для gem, все сработало нормально:

gem 'activerecord', "4.2.7.1"
gem 'actionpack', "4.2.7.1"
рубин-на-рельсы, ActiveRecord, RubyGems,