Ошибка в отношении различных .NET Framework для библиотек

Создан веб-сайт ASP.Net. Он использует .NET Framework 4.5.2.

На этом веб-сайте ссылается одна библиотека классов, в которой используется .NET framework 4.6.1.

Возникла ошибка ( вне сферы действия этого вопроса, какая ошибка ), которая возникает только с .NET Framework 4.5.2.

Ошибка возникает из библиотеки классов, даже если библиотека классов использует .NET 4.6.1, когда веб-сайт использует .NET 4.5.2

Он работает, если я меняю веб-сайт на .NET 4.6.1.

Но я не хочу менять .NET Framework на веб-сайте из-за некоторых других зависимостей. Каково решение этого? Или почему это происходит? Поскольку моя библиотека классов использует .NET 4.6.1, и из этого кода генерируется ошибка. Почему это зависит от моего сайта?

c#,.net,.net-framework-version,

-1

Ответов: 0

Ошибка в отношении различных .NET Framework для библиотек

Создан веб-сайт ASP.Net. Он использует .NET Framework 4.5.2.

На этом веб-сайте ссылается одна библиотека классов, в которой используется .NET framework 4.6.1.

Возникла ошибка ( вне сферы действия этого вопроса, какая ошибка ), которая возникает только с .NET Framework 4.5.2.

Ошибка возникает из библиотеки классов, даже если библиотека классов использует .NET 4.6.1, когда веб-сайт использует .NET 4.5.2

Он работает, если я меняю веб-сайт на .NET 4.6.1.

Но я не хочу менять .NET Framework на веб-сайте из-за некоторых других зависимостей. Каково решение этого? Или почему это происходит? Поскольку моя библиотека классов использует .NET 4.6.1, и из этого кода генерируется ошибка. Почему это зависит от моего сайта?

0-1C # ,. сеть, .net-каркасного версия,
Похожие вопросы