Не удалось установить sami на laravel 5.2.3 для документации api

Я пытаюсь написать документацию для проекта larvel 5.2.3, и я намерен использовать Sami для этого.

Я следил за ссылкой git hub https://github.com/FriendsOfPHP/Sami, и я попытался установить с помощью композитора

композитор требует сами / сами

Но я продолжаю получать ошибку,

Обновление версии 3.3 для sami / sami ./composer.json Загрузка репозиториев композитора с информацией о пакете Обновление зависимостей (включая require-dev) Ваши требования не могут быть разрешены к устанавливаемому набору пакетов.

Задача 1 - Запрос на установку для sami / sami ^ 3.3 -> выполнимый sami / sami [v3.3.0]. - Заключение: удалить symfony / console v3.1.5 - Заключение: не устанавливать symfony / console v3.1.5 - sami / sami v3.3.0 требует, чтобы symfony / console ~ 2.1 -> выполнялся symfony / console [v2.1.0, v2. 1.1, v2.1.10, v2.1.11, v2.1.12, v2.1.13, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.11, v.2.2.2, v.2.2.3, v.2.2.4, v.2.2.5, v.2.2.6, v.2.2.7, v.2.2.8, v.2.2.9, v2. 3.0, v.2.3.1, v.2.3.10, v.2.3.11, v.2.3.12, v.2.3.13, v.2.3.14, v.2.3.15, v.2.3.16, v.2.3.17, v.2.3.18, v.2.3.19, v.2.3.2, v.2.3.20, v.2.3.21, v.2.3.22, v.2.3.23, v.2.3.24, v.2.3.25, v.2.3.26, v.2.3.27, v.2.3.28, v.2.3.29, v.2.3.3, v.2.3.30, v2. 3.31, v.2.3.32, v.2.3.33, v.2.3.34, v.2.3.35, v.2.3.36, v.2.3.37, v.2.3.38, v.2.3.39, v.2.3.4, v.2.3.40, v.2.3.41, v.2.3.42, v.2.3.5, v.2.3.6, v.2.3.7, v.2.3.8, v.2.3.9, v2.4.0, v2.4.1, v2.4.10, v2.4.2, v.2.4.3, v.2.4.4, v2.4.5, v2. 4.6, v2.4.7, v2.4.8, v2.4.9, v2.5.0, v2.5.1, v2.5.10, v2.5.11, v2.5.12, v2.5.2, v.2.5.3, v.5.5.4, v.5.5.5, v2.5.6, v2.5.7, v2.5.8, v2.5.9, v2.6.0, v2.6.1, v2.6.10, v2.6.11, v 2.6.12, v.2.6.13, v.2.6.2, v.2.6.3, v.2.6.4, v.2.6.5, v.2.6.6, v.2.6.7, v.2.6.8, v.2.6.9, v.2.7.0, v.2.7.1, v2. 7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v.2.7.15, v.2.7.16, v.2.7.17, v.2.7.18, v.2.7.19, v.2.7.2, v.2.7.3, v.2.7.4, v2.7.5, v.2.7.6, v.2.7.7, v.2.7.8, v.2.7.9, v.2.8.0, v.2.8.1, v.2.8.10, v.2.8.11, v.2.8.12, v.2.8.2, v.2.8.3, v2. 8.4, v.2.8.5, v.2.8.6, v.2.8.7, v.2.8.8, v.2.8.9]. - Можно установить только один из: symfony / console [v2.3.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.11, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.12, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.13, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.14, v3.1.5]. - Может установить только один из: symfony / console [v2.3.15, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.16, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.17, v3.1.5]. - Может установить только один из: symfony / console [v2.3.18, v3.1.5]. - Может установить только один из: symfony / console [v2.3.19, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.20, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.21, v3.1.5]. - Может установить только один из: symfony / console [v2.3.22, v3.1.5]. - Может установить только один из: symfony / console [v2.3.23, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.24, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.25, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.26, v3.1.5]. - Может установить только один из: symfony / console [v2.3.27, v3.1.5]. - Может установить только один из: symfony / console [v2.3.28, v3.1.5]. - Может установить только один из: symfony / console [v2.3.29, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.30, v3.1.5]. - Может установить только один из: symfony / console [v2.3.31, v3.1.5]. - Может установить только один из: symfony / console [v2.3.32, v3.1.5]. - Может установить только один из: symfony / console [v2.3.33, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.34, v3.1.5]. - Может установить только один из: symfony / console [v2.3.35, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.36, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.37, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.38, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.39, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.40, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.41, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.42, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.4, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.7, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.9, v3.1.5]. - Может установить только один из: symfony / console [v2.5.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.1, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.11, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.12, v3.1.5]. - Может установить только один из: symfony / console [v2.5.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.4, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.7, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.5.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.1, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.11, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.12, v3.1.5]. - Может установить только один из: symfony / console [v2.6.13, v3.1.5]. - Может установить только один из: symfony / console [v2.6.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.4, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.7, v3.1.5]. - Может установить только один из: symfony / console [v2.6.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.6.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.1, v3.1.5]. - Может установить только один из: symfony / console [v2.7.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.11, v3.1.5]. - Может установить только один из: symfony / console [v2.7.12, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.13, v3.1.5]. - Может установить только один из: symfony / console [v2.7.14, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.15, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.16, v3.1.5]. - Может установить только один из: symfony / console [v2.7.17, v3.1.5]. - Может установить только один из: symfony / console [v2.7.18, v3.1.5]. - Может установить только один из: symfony / console [v2.7.19, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.4, v3.1.5]. - Может установить только один из: symfony / console [v2.7.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.7, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.7.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.1, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.11, v3.1.5]. - Может установить только один из: symfony / console [v2.8.12, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.4, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.7, v3.1.5]. - Может установить только один из: symfony / console [v2.8.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.8.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.1, v3.1.5]. - Может установить только один из: symfony / console [v2.1.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.11, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.12, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.13, v3.1.5]. - Может установить только один из: symfony / console [v2.1.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.4, v3.1.5]. - Может установить только один из: symfony / console [v2.1.5, v3.1.5]. - Может установить только один из: symfony / console [v2.1.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.7, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.1.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.0, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.1, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.10, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.11, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.4, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.7, v3.1.5]. - Может установить только один из: symfony / console [v2.2.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.2.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.0, v3.1.5]. - Может установить только один из: symfony / console [v2.3.1, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.2, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.3, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.4, v3.1.5]. - Может установить только один из: symfony / console [v2.3.5, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.6, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.7, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.8, v3.1.5]. - Можно установить только один из: symfony / console [v2.3.9, v3.1.5]. - Можно установить только один из: symfony / console [v2.4.0, v3.1.5]. - Может установить только один из: symfony / console [v2.4.1, v3.1.5]. - Запрос на установку для symfony / console (заблокирован на v3.1.5) -> выполним с помощью symfony / console [v3.1.5].

Является ли Sami несовместимым с Laravel 5.2.3? Поскольку я также попытался добавить более низкую версию Sympony (~ 2.6), но была отображена ошибка, указывающая минимальную версию Sympony для laravel 5.2.3 3.1.5.

Что мне делать?

php,laravel-5,composer-php,

1

Ответов: 1


0

Похоже, что последний официальный релиз v3.3 не поддерживает компоненты symfony3, которые используются laravel 5.3.
Вы можете попробовать установить ветвь dev-master, которая поддерживает symfony3.

composer require sami/sami dev-master

Развертывание dev-master находится в разработке, поэтому у него могут быть некоторые hickup, но я бы поспорил, что он должен работать.

Вы также можете запросить выпуск в репо.

PHP, Laravel-5, композитор-PHP,
Похожие вопросы