Rails теперь работает с Ruby 1.9? [Дубликат]

Возможный дубликат:
возможно ли запустить Ruby on Rails с Ruby 1.9x?

Просмотр в Интернете говорит о том, что Rails не совместим с Ruby 1.9, но я хотел бы знать, всегда ли это так?

И как долго мы должны ждать, чтобы увидеть версию Rails, работающую с Ruby 1.9? Это работает? В дегенерации?

ruby-on-rails,ruby,

2

Ответов: 4


5 принят

Да, последние Rails полностью работают с Ruby 1.9.1.

У вас будут проблемы с gems / plugins, которые могут быть несовместимы. Но все больше и больше популярных gems / plugins теперь работают с 1.9. (Как указано в ссылке Рахула.) См. IsitRuby19.com для информации о совместимости.

Другой аспект заключается в том, что если вы разрабатываете Windows, для Ruby 1.9 еще нет установщика с одним щелчком мыши, поэтому настройка локально может быть больнее, чем того стоит.


2

Надеюсь это поможет:

Rails 2.3 с Ruby 1.9


0

Хорошо, я нашел эту ссылку:

http://guides.rubyonrails.org/2_3_release_notes.html

Действительно, рельсы 2.3 работают с ruby ??1.9 . Это круто!


0

да, но у вас возникнут проблемы с плагинами

рубин-на-рельсы, рубин,
Похожие вопросы